Issues

About: Google Hit Hider by Domain (Search Filter / Block Sites)
When you move the config button to the top that button itself blocks the options button and is almost impossible to click it. Also noticed that when changing the block button to display on mouse over it doesn't work and he button does not appear anymore and changing it back to always doesn't restore it either.

I also noticed that this script seem to mess up with the search result box which causes for some styles like the one you showed me that creates columns on duckduck to generate graphical issues that are not caused by the space the button uses but by other stuff you seem to have changed about the css. Like it seem to mess witht he size and limits of the box. Results that have long tittles will go outside of the designated "result box" and results with long descriptions would occupy more vertical space. Could you check on that?

Thanks for your time for creating this script and maintaining it.

Comentarios

  • Hi Roxz, you can use custom style rules to move the button up the screen a bit and to elevate the settings menu to appear in front of it.

    BEFORE:

    image

    image

    AFTER:

    image

    image

    To add the rule, click Manage Hiding, then the Options tab, scroll to the bottom and click Edit Custom Style Rules. This should open a box at the bottom of the window as shown in the latter two screen shots. Paste these rules:

    .body--serp > #ghhMngBtn{top:6em !important} div.nav-menu--slideout{z-index:3001 !important}

    Click Test and the Manage Hiding button should move. You can click the settings menu to make sure it now appears in front of the Manage Hiding button. If all is well, click Save and you then can close the various forms.

    On Mouseover

    This is working for me. You do need to reload the page after changing this setting.

    image

    Other Display Issues

    I don't know what part of the page has the problem. Could you describe that in more detail or attach a screen shot?
  • editado October 2015 Firefox
    I noticed that the block button disappear if I tick of the autopager option off regardless of it being on mouse-over or always.

    The style you told me is the best one at keeping the boxes perfectly but I was referring to others I'm now using this one https://userstyles.org/styles/111772/duckduckgo-2-columns-and-numbered-results (I changed the % from 45 to 32 to make it 3 columns)
    The issue there is that when I enable your script the results that have longer titles go off the box and the hide button gets placed under the title making the box longer vertically and that disrupts the arrangement of the results leaving blank spaces.

    Examples:

    http://www.imagebam.com/image/64013f440161732


    I tried the other option to place the button on the cite line but it stays on the same place the only change is the appearance of the button. ( http://www.imagebam.com/image/69feb8440160968 )

    With the menu relocation blocking the options I meant this (see image below). But the style rule you said on the previous comment fixes it as well.

    http://www.imagebam.com/image/be1a6b440158540

  • editado October 2015 Firefox
    Roxz dijo:

    I noticed that the block button disappear if I tick of the autopager option off regardless of it being on mouse-over or always.

    The "Instant/AJAX/Autopager" is necessary for sites that use a script to load the results into the page. If you use a search site that composes the entire page on the server, then you can turn this off.
    Roxz dijo:

    I'm now using this one https://userstyles.org/styles/111772/duckduckgo-2-columns-and-numbered-results (I changed the % from 45 to 32 to make it 3 columns)
    The issue there is that when I enable your script the results that have longer titles go off the box and the hide button gets placed under the title making the box longer vertically and that disrupts the arrangement of the results leaving blank spaces.

    Regarding the title overflowing the box, are you still using version 1.6.9? That problem should be fixed in the current release (1.7.0).

    The block button being on a later line, yes, there's no room for it after the ... on most titles, so it wraps to the next line. You could overlay it over the end of the title if you don't mind blocking the last few characters (it's not bad with "On Mouseover"). The custom style rule would be as follows:

    .ghhb{position:absolute;right:0}
    Roxz dijo:

    I tried the other option to place the button on the cite line but it stays on the same place the only change is the appearance of the button.

    Yeah, the script is looking for a cite line like the green text on Google which actually uses the HTML <cite> tag. I forgot to code for the DDG cite line (at the bottom of the result) that doesn't use a <cite> tag.
    Roxz dijo:

    With the menu relocation blocking the options I meant this (see image below). But the style rule you said on the previous comment fixes it as well.

    Again, this should not happen in 1.7.0. I fixed the z-index parameters of the various dialog boxes to appear in front of buttons in the current release.
  • editado October 2015 Firefox
    Updating and using that style rule fixed it all. Thanks a lot. I don't know why it didn't auto update.

    If you don't mind and if it's not to difficult to do do you know if there is a way to use the add-on Search preview without breaking the style? If I use it it only shows one column and on long titles the image gets placed over the title increasing the result box instead of staying o the left it's left.

    https://addons.mozilla.org/en-US/firefox/addon/searchpreview/

  • Here's a partial fix to get back to 3 columns. Add a clear:none in the userstyle here:
    #links_wrapper #links .result
    {
    width: 32%;
    min-height: 8.2em;
    float: left;
    clear: none !important;
    }
    But... I have a rule in Google Hit Hider that prevents the result wrapping up next to the preview image. That rule is needed to see the entire block dialog if you click the block button. It can be redesigned, but not in the immediate future...
  • Thanks that works. I'll be looking forward to the complete fix but don't worry there is no need to rush it or anything. Thanks again for all your help.
Accede o Regístrate para comentar.