Greasy Fork is available in English.

Google Cache Highlight Search Query Terms for HTTPS

Restore highlighted search terms in Google cache for secure searches. For Firefox+Violentmonkey or Chrome+Tampermonkey. v0.6.6 2023-06-19

< Valutazione su Google Cache Highlight Search Query Terms for HTTPS

Recensione: Bene - lo script funziona

§
Pubblicato: 07/08/2015

Bug since this mornig.

The script no longer work for me, I tried the script on a new profile too and same results.

If I want to open the "Cache" link/page it give me a warning redirection warning http://i.imgur.com/93f5mTH.png and if I follow the cache page I have the "regular" page with nothing highlighted ---> http://i.imgur.com/dgbY911.png

If I disable the script I have no longer any redirection and go straight to the "plain" google cache page.

Regards

-------------------------

Also I have a question (not about this script) for you Jefferson, since you seem to have a very good knowledge of google search. I tried to find an answer for a bug/annoyance since few days and I'm not able to find any fix for that.

When I use the advanced search with a custom range date for the search (using the calendar with mouse for the selection) Google give a bad date format on his own search ????

The only thing I've found on the web about it is this link https://www.seroundtable.com/google-news-date-bug-14480.html from 2011... so it seem a pretty old bug/annoyance ! :( The link show the bug on a video and describe it a lot better than I do ;-)

Do you think you can do a small script to fix the "date format" automatically in the date range advanced search option ?

Thanks a lot for all your Timesaver Scripts ????????????

§
Pubblicato: 07/08/2015

Hi Mikhoul, what was the address of the search results page you started from? I want to see whether I get the same result.

Also, could you try changing the HTTPS setting if that is turned on? https://greasyfork.org/en/scripts/1681-google-cache-highlight-search-query-terms-for-https#additional-info

Regarding the date format, I live in an mm/dd/yyyy country and as long as I use a four-digit year, it seems to work fine. However, I have heard about problems before with some confusion on the Google results page with dd/mm/yyyy dates. I'm not sure of the best solution but I could test using your results page link.

§
Pubblicato: 07/08/2015

Thanks for the quick reply Jefferson.

Here's a search URL https://www.google.ca/search?q=auto&gws_rd=ssl

"USE HTTPS" setting was active and I tried to disable it and when it was disabled I did not receive the redirection warning but there was no word highlighted.

Also for your other script I don't see the "block" button http://i.imgur.com/WqBGypP.png even if it seem enabled.

Here's a screencast to show you better: http://screencast-o-matic.com/watch/cojiYef4b1

-----------------------------------

For the date format "bug" I see it seem related to the country...

I see lot of complaint from various users around the world about this annoyance but no real practical solution.

I'm located in Canada and my main language is French.

Here's a screenshot of the bug, the RED color entry is the wrong format picked with the mouse and the Green is the good entered manually. http://i.imgur.com/KyTkFI9.png

May be a script could parse the Field "From" and the field "To:" to check if the format is the a "valid" format and if not it change it to YEARS-Month-Day ?


Thanks a lot for the quick reply ! 8-)

§
Pubblicato: 07/08/2015

I was not able to replicate the problem with either Google Hit Hider buttons or the cached link. I noticed you get localized results (map and places results) which I do not get, and that might have something to do with it.

But the bigger mystery is that your En cache link is running through the tracking link (google.ca/url?) instead of loading the cached page directly (see attached fifth image). I haven't seen that before and do not see that on my visit (see attached sixth image).

The way the tracking link is added to the main result link is to add an onmousedown event handler into the link, but I don't see such a handler when I visit the page. Maybe Google is experimenting on you??

Could you post the "modified" HTML source of the whole results area below the navigation buttons? The easiest way is to select all by pressing Ctrl+a, then right-click > View Selection Source. In the source viewer, it should be tightly packed HTML and style rules that go on forever. As shown in the seventh attached image, use Find (Ctrl+f) to look for this:

id="ires"

Then select from the which precedes that all the way to the bottom of the document, and paste into http://pastebin.com/ (no registration required), save the page, and post the new link back here.

§
Pubblicato: 07/08/2015

I found the culprit for the 2 add-ons with you tips about tracking link, it was this add-on https://addons.mozilla.org/en-US/firefox/addon/google-search-link-fix/ that was incompatible.

I think it was installed from one of my old computer that I put in sync with Firefox this week, that's why it was working and suddenly stop .

Sorry for the "false" bug... ;-)


Do you think you could "fix" the annoying "date format" bug for foreign users ?

Best Regards and thanks again for your quick reply.

§
Pubblicato: 07/08/2015
Modificato: 07/08/2015
Here's a screenshot of the bug, the RED color entry is the wrong format picked with the mouse and the Green is the good entered manually. http://i.imgur.com/KyTkFI9.png

It's strange, the date picker works when the language is English but is broken when the language is French. I think one approach would be to attach a mouseover event to the "Aller" button that would fix the dates right before you click. Trying to fix it later would, I think, be too complicated. But this probably is a subject for a different thread.

You might want to request it here since I don't know how soon I'll look back in on it: https://greasyfork.org/en/forum/categories/script-requests

§
Pubblicato: 08/08/2015

Thanks a lot I will request it on the right forum, it's very strange that Google did not fix it many years ago, it will take them 15 minutes ;-)

Pubblica risposta

Accedi per pubblicare una risposta.