Greasy Fork is available in English.

CSP - Upgrade Insecure Requests

Tries to upgrade HTTP assets to HTTPS using CSP

Autor
r-a-y
Denně instalací
0
Celkem instalací
5
Hodnocení
0 0 0
Verze
1.0.0
Vytvořeno
01. 11. 2020
Aktualizováno
01. 11. 2020
Licence
neuvedeno
Spustit na
všech stránkách

If you're using Firefox 83, just use the built-in HTTPS-only mode.

For everyone else, this userscript attempts to upgrade all HTTP assets to HTTPS using the upgrade-insecure-requests CSP directive. This should fix some mixed content issues that are popping up more on more on updated browsers.

You might also want to check out my Force HTTP to HTTPS userscript if you want to force HTTP sites to HTTPS on a manual basis.