Greasy Fork is available in English.

RU AdList JS Fixes

try to take over the world!

Autor
Lain inVerse
Denně instalací
41
Celkem instalací
240.905
Hodnocení
320 91 23
Verze
20240625.1
Vytvořeno
26. 05. 2016
Aktualizováno
24. 06. 2024
Kompatibilita
Kompatibilní s Firefox Kompatibilní s Chrome Kompatibilní s Opera Kompatibilní s Edge
Licence
CC-BY-SA-4.0
Spustit na
všech stránkách

Вспомогательный скрипт для подчистки сайтов после Adblock Plus со списком фильтров RU AdList.

Для использования в uBlock Origin просто подпишитесь на фильтр RU AdList: Counters.

Особенности установки

Скрипт совместим с расширениями Tampermonkey и Violentmonkey. Greasemonkey и Adguard не поддерживаются из-за технических ограничений данных расширений как то запуск скрипта перед скриптами страницы и права доступа к свойствам window.

Обычно Violentmonkey дополнительной настройки после установки не требует, но на некоторых сайтах он не успевает. Для исправления слева на странице расширения (клик по иконке расширения, клик по шестеренке) откройте Настройки и поменяйте "Режим синхронизации" на "page".

При использовании Tampermonkey 5.1 (MV2) зайдите в панель управления (в меню расширения, Dashboard), Настройки (вкладка Settings). Поменяйте режим с "Новичок" (Novice) на "Продвинутый" (Advanced). Прокрутите страницу в самый низ и поменяйте режим встраивания (Inject Mode) на Мгновенный (Instant). В Tampermonkey 5.2+ (MV3) такой настройки больше нет и связано это с Хромом. Пока могу только посоветовать поменять браузер. Если вы используете Firefox версии 58 и более старых версий (или другой браузер на основе Firefox этих версий), то данная настройка может привести к проблемам с авторизацией на некоторых сайтах. Кроме того, при использовании TM с Firefox найдите раздел "Безопасность" (Security) и измените "Content Script API" на "UserScripts API Dynamic" и нажмите "Сохранить" внизу этого раздела. Этот API работает лучше, чем режим мгновенного встраивания на сайтах, активно использующих CSP.

The script is compatible with the Tampermonkey and Violentmonkey extensions. Greasemonkey and AdGuard are not supported due to the technical limitations of these extensions, such as launching a script before page scripts and access rights to window properties.

Usually, Violentmonkey does not require additional configuration after installation, but on some sites it isn't fast enough. To fix this, open Settings on the left side of the extension’s page (click on the extension’s icon, click on the gear) and change "Injection mode" to "page."

In the case of using Tampermonkey 5.1 (MV2) go to the Control Panel (extension’s menu, Dashboard), Settings tab. Change the mode from Novice to Advanced. Scroll to the bottom and change Inject Mode to Instant. If you are using Tampermonkey 5.2+ (MV3) this option doesn't exist anymore and this is due to changes in Chrome. I can only suggest switching to another browser for now. If you are using Firefox 58 and older versions (or another browser based on old Firefox versions), then this setting can lead to authorization problems on some sites. Additionally, when using TM with Firefox, you may want to locate the "Security" section, change "Content Script API" to "UserScripts API Dynamic," and press "Save" at the bottom of that section. This API works better than instant injection mode at sites actively using CSP.

СОВМЕСТИМОСТЬ / COMPATIBILITY

Fx56 и ниже не поддерживается.

Существующий код поддержки будет постепенно устраняться если будет мешать. Скрипт проверяется в актуальных версиях Google Chrome и Mozilla Firefox для ПК. Стабильная работа скрипта в Firefox 52-58 не гарантируется, а некоторые функции не работают вовсе. Форки Firefox, в которых не работает Tampermonkey, не поддерживаются. Использование на мобильных устройствах возможно при условии использования Mozilla Firefox и Tampermonkey, но работоспособность там не проверяется.

Fx56 and below are not supported.

Existing compatibility code will be phased out if it gets in the way. The script is checked in the current versions of Google Chrome and Mozilla Firefox for PC. Stable operation in Firefox 52–58 is not guaranteed, and some features may not work at all. Firefox forks without Tampermonkey support are not supported. It’s possible to use it on mobile devices provided you have Mozilla Firefox and Tampermonkey there, but operability there is not checked.

Tampermonkey 5.0.0 + Firefox.

Некоторые сайты могут не работать при первом открытии страницы. Обновление страницы проблему обычно решает при условии, что Tampermonkey настроен как указано выше в описании.

Some sites may not work when you first open the page. Refreshing the page usually resolves the issue, provided that Tampermonkey is configured as indicated above in the description.