您好,游客!

您好,新朋友。点击以下按钮加入我们!

Script does not work

About: Youtube No Autoplay - Disable "Up Next"

It used to work fine, now it does not anymore, even after uninstalling and reinstalling the latest version.
I am on Firefox 66.0.5 used on Linux Mint 19.1.

评论

  • Please be sensible and give it a blue rating, especially when it isn't even clear if the error is truly on my side. It could be because of your browser settings and userscript manager. I maintain this in my free time and try to be helpful.

    What are you using? Violentmonkey, Tampermonkey, Greasemonkey?
    Are cookies enabled, disabled? On what video and youtube design does the bug manifest?

    A bit more input please. From a Linux friend I would love a properly filed bug report.

  • Your account was made literally 1 minute before you made your post and you ignore my reply. I guess this is just an attempt of yours to downvote intentionally.

  • @yakumo_ran said:
    Your account was made literally 1 minute before you made your post and you ignore my reply. I guess this is just an attempt of yours to downvote intentionally.

    I have no idea what you are talking about here. I signed in with my Github account, which was made years ago. So, before you jump to conclusions about downvoting and get from 1+1=3, I suggest you had better know what you are saying. And if you can't stand the heat, get out of the kitchen.

  • @yakumo_ran said:
    Please be sensible and give it a blue rating, especially when it isn't even clear if the error is truly on my side.

    I don't see any colour indication for a blue rating. The only option that corresponds to my experience, i.e. "script not working", is the option "Bad". I have changed that into the open option, if that's what you mean by "blue".

    It could be because of your browser settings and userscript manager. I maintain this in my free time and try to be helpful.

    I understand and appreciate that, which is why I gave you feedback. I could also not have bothered, uninstalled the script, and find something else.

    What are you using? Violentmonkey, Tampermonkey, Greasemonkey?

    Violentmonkey

    Are cookies enabled, disabled?

    My setting is: Delete cookies and site data when Firefox is closed

    On what video and youtube design does the bug manifest?

    On all of them.

    A bit more input please. From a Linux friend I would love a properly filed bug report.

    I hope this helps.

  • 最后编辑于 May 18 [?]

    Alright then, a misunderstanding. I just tried everything to reproduce your issue:
    1) Installed same Firefox version 66.0.5 as you, since I was on the ESR.
    2) Installed Violentmonkey, since I use Tampermonkey.
    3) Clean fresh Firefox profile with only Script+Manager.
    4) Set "Delete cookies and site data when Firefox is closed".

    The bug is impossible to reproduce. I doubt that installing Mint in a virtual machine would allow me to reproduce it either.

    Have you tried backing up your Firefox profile?
    (CTRL+H to make hidden directories visible, then zip the profile dir?)
    ~/.mozilla/firefox/<profile directory>
    Should be your path on *NIX.

    After that you could try deleting your prefs.js or disable addons until you find the cause why it is not working. Only of course if you want to keep testing.

    I really try to take bug reports seriously, but I need lots of details to reproduce a bug. Everyone configures their Firefox a little different to their needs.

  • I understand, and sorry if I sounded a bit rough. I tried an about:config setting, that did not work either. Rather than mess with the prefs.js file, I'll leave the autoplay feature as is and live wit it.
    BTW, your script did work, then stopped. Possibly an add-on, possibly another about:config setting. So the problem is likely on my side.
    My apologies for disturbing you.

  • Yeah, I am sorry as well for being so paranoid. Be safe and have a good Sunday.

登录注册后才能评论。