Này người xa lạ!

Còn chờ gì nữa mà không mau đăng nhập hoặc đăng ký để cùng tham gia thảo luận với cộng đồng!

Button Unresponsive 6/19 update, Chrome/Violentmonkey/fanfiction.net

About: Fanfiction Qomplete

Since the 6/19 update, the Qomplete! button stopped working in Chrome (Violentmonkey 2.10.5), on fanfiction.net story pages and review pages. Haven't tried any other sites.

When you press it, it doesn't really 'click,' it just sort of Highlights the button, and is otherwise unresponsive.
Issue still exists in the 6/24 update.

Checking the console, I get this every time it's clicked:

VM538:167 Uncaught (in promise) ReferenceError: GM is not defined
at readSettings (:167:29)
at HTMLButtonElement.runFFQomplete (:87:24)
readSettings @ VM538:167 [line 167: settings[i] = await GM.getValue(i, 0)]
runFFQomplete @ VM538:87 [line 87: var settings = await readSettings()]
async function (async)
runFFQomplete @ VM538:87 [line 87: var settings = await readSettings()]

I have an old version prior to 6/19 that still works, so it's not really a pressing issue for me, but figured I'd pass along my findings, as I hadn't seen anything else posted since it started happening. I reproduced it on another machine, all other extensions disabled, so I don't think it's unique to me.
If it is, my bad :tongue:

Otherwise, I love the script! Especially since you added support for Review pages on ff.net!
Thanks!

Bình luận

  • Thanks for your nice report :)

    Sounds like Violentmonkey is bugged. It works in Greasemonkey on Firefox and tampermonkey in Chrome.

    At https://chrome.google.com/webstore/detail/violentmonkey/jinjaccalgkegednnccohejagnlnfdag it says:
    "- GM functions are supported."

    So it should work. So it's a bug in Violentmonkey that prevents my correct code from working.

    To explain further: The new FFQ version (2019-06-19) was an update to use the new GM API. It seems like Violentmonkey 2.10.5 hasn't been updated to support the new API. So it's an outdated addon. The reason the old version worked was because the the outdated userscript version works with the outdated userscript manager.

    Since the browsers changed to the new API months and months ago and Violentmonkey still doesn't support it (even though that version was released fairly recently 2019-05-06) it seems like it isn't actually being maintained and you should probably switch to a modern userscript manager like Tampermonkey.

    It's not really possible for me to fix it since the problem is in the userscript manager and not in my code. But I haven't tested running Violentmonkey so I could be mistaken. I might do that later, it might be possible to do some workaround so that the code still "works" for Violentmonkey users even though some features (saving settings) will be missing.

  • Thanks for the update!
    I guess I'll check out Tampermonkey when I get a chance. As I said, it isn't an issue for me right now, but figured I'd pass the info along to you.
    Thanks again for the great script :D

Đăng nhập hoặc Đăng ký để gửi bình luận.