Này người xa lạ!

Còn chờ gì nữa mà không mau đăng nhập hoặc đăng ký để cùng tham gia thảo luận với cộng đồng!

I can’t set Webhook syncing on one of my scripts

Hello,

All my scripts are in same github.
I think I have imported all of them the same way (using the import link).

One of them is not in webhook syncing (it can only be set in Manuel or Automatic syncing).
Automatic Syncing is quite the same result except that it won’t display the changelog from git.
I would like to know how to activate Webhook for this script (I already tried reimporting and it’s same).

Bình luận

  • Which script is the problem one?
  • It’s called mb. MERGE HELPOR 2.
    I see it as automatic syncing in webhook info page and its Sync page only has auto and manual syncing available.

    OH maybe I get it, it’s the only script that has some %20 in its path !

  • Could be the spaces. Can you go into Github, go to your project settings, Webhooks & Services, click on your Greasy Fork webhook, go down to Recent Deliveries, copy the Request Payload and Response Body for a commit that should have updated this script, and paste it here?
  • Sure ! Here is the request and the response for 0b909980-a17c-11e4-90ec-87bea0c6337a delivery that took place on 2015-01-21 at 15:44:47.

  • Yeah, I think it was the space. Try now.
  • Thank you, I was waiting to update this same script and now I have done it.
    But now the webhook has another error :

    We couldn’t deliver this payload: Invalid host name.

    cf. https://pastee.org/bv87j

  • It eventually worked today… no idea why it was broken.
    It updated one last time (probably) in automatic but now it is well set to Webhook.
    I have another script with some spaces that is in automatic, but I guess it will be ok next time too… :)
    Thanks

Đăng nhập hoặc Đăng ký để gửi bình luận.