wrong year in version number

About: OpenUserJS Bullshit Filter [Preview]

wrong year in version number → script not autoupdated
previous version was v2019.2.4 (04.02.2019)
this version is v2018.9.20 (27.10.2019) → for autoupdate it must be v2019.9.20

and please, next time, use 2 symbols for "month" and for "day" in version number
v2019.2.4 → v2019.02.04
v2018.9.20 → v2019.09.20 or v2019.10.27
so no need to correct 10/11/12 to 9

Komentáre

  • zemené November 2019 [?]

    Fist of all, thanks for letting me now and sorry about this:
    the last version I uploaded by mistake was a previous version from last year.
    In any case, I didn't want to make any actual change in the code - just a change in the file encoding (from 'UTF-8 with BOM' to 'UTF-8'), that's why I didn't want to bump the script version, just like I did with various other scripts I did the same change in the file encoding with that commit.


    Regarding:

    use 2 symbols for "month" and for "day" in version number

    sorry, but I want to stick to the one-digit pattern, similar to what they use in 'Refined GitHub' versioning.

  • if you can use v2019 → уou can use v20190920 or v20191027 without "point" in it …
    so no need use "one-digit pattern" …

  • That way (e.g. v20190920 or v20191027) it would become less easy to perceive.

    In any case, I don't agree with your suggestion. I prefer the months to have in most cases (Jan-Sept) one digit.

Táto diskusia bola uzavrená.