Greasy Fork is available in English.

RU AdList JS Fixes

try to take over the world!

Автор
Lain inVerse
Установок в день
88
Всего установок
57 055
Оценки
200 38 15
Версия
20200922.1
Создан
Обновлён
Лицензия
Недоступно
Работает на
Все сайты

Вспомогательный скрипт для подчистки сайтов после Adblock Plus / uBlock Origin со списком фильтров RU AdList.

Особенности установки

Скрипт совместим с расширениями Tampermonkey и Violentmonkey (за исключением версии для Firefox последнего). Greasemonkey и Adguard не поддерживаются из-за технических ограничений данных расширений как то запуск скрипта перед скриптами страницы и права доступа к свойствам window. Violentmonkey в Firefox не поддерживается из-за неумения обходить в нём CSP, что блокирует запуск скрипта на сайтах Яндекса и некоторых других.

Violentmonkey дополнительной настройки после установки не требует, но до выхода 2.12.8 скрипт может не работать на некоторых сайтах. При использовании Tampermonkey в актуальных версиях браузеров зайдите в панель управления (в меню расширения, Dashboard), Настройки (вкладка Settings). Поменяйте режим с Новичок (Novice) на Продвинутый (Advanced). Прокрутите страницу в самый низ и поменяйте режим встраивания (Inject Mode) на Мгновенный (Instant). Если вы используете Firefox 58 и более старых версий (или другой браузер на основе Firefox этих версий), то данная настройка может привести к проблемам с авторизацией на некоторых сайтах.

The script is compatible with Tampermonkey and Violentmonkey extensions (except Firefox version of the latter). Greasemonkey and Adguard are not supported due to technical limitations of these extensions, such as launching a script before page scripts and access rights to window properties. Violentmonkey in Firefox is not supported due to the inability to bypass CSP in it, which blocks the launch of the script on Yandex and some other sites.

Violentmonkey does not require additional configuration after installation, but before the release of 2.12.8 the script may not work on some sites. In case of using Tampermonkey in a modern browsers go to the Control Panel (extension's menu, Dashboard), Settings tab. Change the mode from Novice to Advanced. Scroll to the bottom and change Inject Mode to Instant. If you are using Firefox 58 and older versions (or another browser based on Firefox of these versions), then this setting can lead to authorization problems on some sites.

СОВМЕСТИМОСТЬ / COMPATIBILITY

Поддержка Fx56 и ниже будет прекращена осенью 2020 года.

Работоспособность скрипта проверяется в актуальных версиях Google Chrome и Mozilla Firefox для ПК. Стабильная работа скрипта в Firefox 52-58 не гарантируется, а некоторые функции не работают вовсе. Форки Firefox, в которых не работает Tampermonkey, не поддерживаются. Использование на мобильных устройствах возможно при условии использования Mozilla Firefox (но не Beta/Preview) и Tampermonkey, но корректная работоспособность не проверяется.

Support of Fx56 and below will be removed in Fall 2020.

Script's workability is checked in the current versions of Google Chrome and Mozilla Firefox for PC. Stable operation in Firefox 52-58 is not guaranteed, and some features may not work at all. Firefox forks without Tampermonkey support are not supported. It's possible to use it on mobile devices provided you have Mozilla Firefox (not the Beta/Preview, though) and Tampermonkey there, but workability is not checked.