脚本在waterfox上不起作用,调试页面显示错误

About: iciba划词翻译
redigerte April 2019 i Script Discussions [?]

本人使用win7 waterfox 56.2.8 + tamermonkey
GF网站怎么连图片都无法上传成功了
显示如下错误
ERROR: Execution of script 'iciba划词翻译' failed! u.attachShadow is not a function userscript.html:4:347 tms_93a1d2ad_79d9_4340_9e14_cd63ea497a5b/<@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:39:763559 n@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:28:105 tms_93a1d2ad_79d9_4340_9e14_cd63ea497a5b/<@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:39:556426 n@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:28:105 tms_93a1d2ad_79d9_4340_9e14_cd63ea497a5b/<@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:28:902 tms_93a1d2ad_79d9_4340_9e14_cd63ea497a5b@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:28:2 g</<@eval:2:492 anonymous/<@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:4:1 anonymous/<@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:3:55 anonymous@moz-extension://33650335-27c4-4dc3-8e71-35ba21143f23/userscript.html?id=93a1d2ad-79d9-4340-9e14-cd63ea497a5b:3:2 g</<@eval:2:492 E_c@eval:3:306 ja@eval line 1 > Function:63:201 create@eval line 1 > Function:75:51 c@eval line 1 > Function:16:270 userscript.html:4:424

Kommentarer

  • 因为waterfox最新版使用的是firefox 57的内核,而firefox在57之后完全抛弃了之前的扩展api。attachShadow是在firefox59可以通过设置参数开启,或者在firefox63正式支持。所以目前脚本需要的api在waterfox不支持。

    3.3.1版本没有使用到attachShadow,可以在waterfox上使用。最新版的脚本只能在chrome53+ firefox 63+ 运行。

  • 4.1.2更新了shadow dom v0的支持,理论支持到firefox 29。你可以安装最新版试试。需要在about:config 开启 dom.webcomponents.enabled
    https://www.caniuse.com/#search=shadowdom

  • @noe132 说道:
    4.1.2更新了shadow dom v0的支持,理论支持到firefox 29。你可以安装最新版试试。需要在about:config 开启 dom.webcomponents.enabled
    https://www.caniuse.com/#search=shadowdom

    现在又出现相同的错误,无法运行了,waterfox 56.2.9
    脚本:4.2.1

  • 4.2.2已修复。

  • @noe132 说道:
    4.2.2已修复。

    最新版又不支持了 Waterfox 56.2.10

Logg inn eller Registrer deg for å kommentere.