Greasy Fork is available in English.

Neverwinter Gateway - Professions Robot

Automatically selects professions for empty slots

< Valutazione su Neverwinter Gateway - Professions Robot

Domanda/commento

§
Pubblicato:
Modificato:
Help adding gather + refine

I'm trying to also add gather and refine for artificing and leatherworking.
But for some reason it won't work for me.

Example:
2: ["Artificing_Tier1_Icon_Virtuous_1", "Artificing_Tier3_Gather_Basic", "Artificing_Tier3_Refine_Basic", "Artificing_Tier2_Gather_Basic", "Artificing_Tier2_Refine_Basic", "Artificing_Tier1_Gather_Basic", "Artificing_Tier1_Refine_Basic"],


I use above line for entries 1: to 19: for artificing.

What am I doing wrong here ?
§
Pubblicato:
Modificato:
If "it won't work" means:

-it doesn't start the listed jobs but something else, try the "clear tasks" button

-it starts "gather" but not "refine" (based on the order you posted them), that's because the script tries to start as many "gather" it can, if it can't it proceeds to the next task listed, in this case "refine". Note that you can start as many gather (or refine if you have the resources needed) as you want, as opposed to some other tasks that are limited (for example in leadership you can have only 3" wargame training" running at a time), so the script fills all your job slots with the "gather" job.

-some tasks depend on the profession level: if your level 2, the tier3 and tier2 jobs ii believe aren't available till later

If you put "gather" and then "refine" because your goal is to have refined resources, you can omit the gather job, the script executes the gather on its own if the refine job doesn't have the needed resources.
Same goes for the "Artificing_Tier1_Icon_Virtuous_1" job: if your goal is only this, you can omit the other jobs (unless the icon job can be started only X times, so the gather and refine jobs are used to fill slots otherwise unused).

Hope it helps
§
Pubblicato:
I understand what your are saying, but it's still not doing anything.

Now using: ["Artificing_Tier1_Icon_Virtuous_1", "Artificing_Tier3_Refine_Basic", "Artificing_Tier3_Gather_Basic", "Artificing_Tier2_Refine_Basic", "Artificing_Tier2_Gather_Basic", "Artificing_Tier1_Refine_Basic", "Artificing_Tier1_Gather_Basic"],

With or without editing the script, since I ran out of materials and residuum it's not doing anything.

Leadership is going fine. It's just my artificing and leatherworking not gathering or refining anything.
§
Pubblicato:
I understand what your are saying, but it's still not doing anything.

Now using: ["Artificing_Tier1_Icon_Virtuous_1", "Artificing_Tier3_Refine_Basic", "Artificing_Tier3_Gather_Basic", "Artificing_Tier2_Refine_Basic", "Artificing_Tier2_Gather_Basic", "Artificing_Tier1_Refine_Basic", "Artificing_Tier1_Gather_Basic"],

With or without editing the script, since I ran out of materials and residuum it's not doing anything.
What level your Artificing is, how many slots/workers and Rank of your workers for Artificing, what resources you have Gold/Residuum (artificing).

Is BOt settings correct, "Buy resources" , "Train assets", + let script attempt to reload and login automaticly.

Look this Artificing list, I will not look tasks what not need residuum, but gathering+refining can be done, dont mix up higher level task on lover level list.

To populate all slot per level just add,

"Artificing_Tier1_Refine_Basic" and script fill up all slots with it and it must be last so script try use other task before (can call it "falback option"), any level and worker can do this.

"Artificing_Tier2_Refine_Basic", look what level can do this task and add it before Tier1 REfining -task, now you have 2x Fallback option.

"Artificing_Tier3_Refine_Basic", again look what level can do this task and add it before Tier2 Refining -task so now you have 3x Fallback option.

...posting list later, its just copy paste/check prof. level task.
§
Pubblicato:
Test this and make your own edit,

0:["Artificing_Tier0_Intro_1"],
1:["Artificing_Tier1_Symbol_Virtuous_1","Artificing_Tier1_Refine_Basic"],
2:["Artificing_Tier1_Icon_Virtuous_1","Artificing_Tier1_Refine_Basic"],
3:["Artificing_Tier1_Icon_Virtuous_1","Artificing_Tier1_Refine_Basic"],
4:["Artificing_Tier1_Icon_Virtuous_2","Artificing_Tier1_Refine_Basic"],
5:["Artificing_Tier1_Icon_Virtuous_2","Artificing_Tier1_Refine_Basic"],
6:["Artificing_Tier1_Icon_Virtuous_2","Artificing_Tier1_Refine_Basic"],
7:["Artificing_Tier1_Icon_Virtuous_2","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
8:["Artificing_Tier2_Icon_Virtuous_3","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
9:["Artificing_Tier2_Icon_Virtuous_3","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
10:["Artificing_Tier2_Icon_Virtuous_3","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
11:["Artificing_Tier2_Icon_Virtuous_3","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
12:["Artificing_Tier2_Icon_Virtuous_3","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
13:["Artificing_Tier2_Icon_Virtuous_3","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
14:["Artificing_Tier3_Icon_Virtuous_4","Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
15:["Artificing_Tier3_Icon_Virtuous_4","Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
16:["Artificing_Tier3_Icon_Virtuous_4","Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
17:["Artificing_Tier3_Icon_Virtuous_5","Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
18:["Artificing_Tier3_Icon_Virtuous_5","Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
19:["Artificing_Tier3_Icon_Virtuous_5","Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
20:["Artificing_Tier3_Refine_Basic","Artificing_Tier2_Refine_Basic","Artificing_Tier1_Refine_Basic"],
§
Pubblicato:
I tried your task list, my artificing is level 1, and it correctly starts the tier1_refine_basic after skipping the others since i can't start them (level too high).

Try looking at the debug messages in the console, it may shed some light on what's wrong.
Don't forget to tick the "enable debug" in the script settings.
Console should be ctrl+shift+j.

I tried replicating your problem and i did, but the reason was that the script didn't see the updated task list:
in the console log if you see a line like this

"Weaponsmithing" "is level" 8 [or artificing/letherworking for you]
"createNextTask" 1 0

the importat bit is the "1 0": this 2 numbers are the lenght of the task list ("1") and current task the script is trying to start ("0", that is really the first).
The first number should have been 2 (i put 2 tasks in the job list, a dagger and then a gather; for your task list it should have been 7): this means the script doesn't see the jobs you specified.
Try "clear tasks"/"save tasks" and/or closing and reopening the browser: after that the script decided to work.

It happened other times to me that it kept doing old jobs and not the new i put in the script.
§
Pubblicato:
Modificato:
Thanks for the help guys ;)

I think my problem was somewhere else.
I uninstalled everything, and started from the beginning.
It's working fine now, it instantly started Guard Duty + Cure Simple Pelts + Craft Ornamental Metal and Carved Wood.

The weird thing is that I tried this before, just throwing everything away and starting over, but yeah it works now.

Just to be sure i'm using Rotten_mind's list now.

Thanks again <3

Pubblica risposta

Accedi per pubblicare una risposta.