Greasy Fork is available in English.

soundcloud disable autoplay station

Opens the Soundcloud Next Up menu on load and turns off the Autoplay Station, then continually disables it

< Valutazione su soundcloud disable autoplay station

Recensione: Bene - lo script funziona

§
Pubblicato:
Modificato:
I just want to say this: Thank you so fucking much for this script!

Every single god damned time I would open soundcloud to play a track I'd forget to manually disable autoplay and proceed to have the shit scared out of me for the nth time by "Sonic - 'Green Trill Zone' (Trap Remix)' which would invariably start playing at the conclusion of whatever I was listening to resulting in headphones being thrown off and a massive spike of adrenaline, as well as possible hearing damage. I actually kind of like the song but I had no idea that "liking" it would cause it to be played automatically, every single fucking time.

So thank you. Thank you for VASTLY improving my soundcloud experience, saving my sanity, and my hearing as well. It is a disgrace that autoplay isn't tied to your account settings and remembered from one session to another. This is the next best thing.

That said, I do have one request for possible improvement: in addition to disabling autoplay every time, could you have the script also hit the "Clear" button as well? When I go to my profile I see a bunch of the sound files I've uploaded on the same page. When I go to this page, a bunch of shit (everything on this page plus everything from my history apparently) gets put in my "Next Up" queue. And even though autoplay is disabled, it still plays for some reason. However, if I Clear the queue and play a track, it doesn't go to the next one on the page.

Oh, one more thing - would it be possible to also have the script set the volume slider (SoundCloud's volume slider in the little toolbar at the bottom) to a certain level? Perhaps this option and the one mentioned above (to clear the queue) could be "commented out" in the script and enabled simply by deleting the necessary characters?
bhackelAutore
§
Pubblicato:
Glad you enjoy the script - your scenario of random songs playing is extremely relatable.

I'm having some trouble understanding what you are looking for with clearing the queue. Since the script runs continually every 2 seconds, clearing the queue would mean that only the currently playing song would play. However, I could make it clear the queue at the start when the website loads, which may or may not be what you are looking for.

The volume slider seems pretty easy, but I would create a different script for it since it is somewhat unrelated. I am just curious what the issue is for that, since I thought the volume level stays through tabs being closed, browser restarted, etc.
§
Pubblicato:
https://www.youtube.com/watch?v=cY66i2bifUo

Here's what's happening. Even though I clear the queue, it re-populates whenever I refresh the page or navigate to another one. And the real problem is that autoplay is still taking place even though it's clearly being disabled by your script!

The queue automatically re-populating with a bunch of shit that I don't want is really annoying, and that's one reason that I'd like it to be cleared perhaps every time the website is loaded or I navigate to a different page within the website. But the other reason is because it seems autoplay is still happening despite being disabled...
bhackelAutore
§
Pubblicato:
Sorry, could you make the video public/unlisted?
bhackelAutore
§
Pubblicato:
guessing you should ignore whatever that is above ^
§
Pubblicato:
Lmao, I saw that earlier; looks like it's gone now.

Video should be viewable now; let me know if it's not.
bhackelAutore
§
Pubblicato:
Ah okay, I think I see what's going on here. When you click on a track, you expect only that one track to play, right? SoundCloud does not really work that way because of the queue, but I think I can still solve it by constantly clearing the queue in the background. I'll see what I can do.
bhackelAutore
§
Pubblicato:
updated, see if that works. remember to remove the comment on line 63
§
Pubblicato:
How do I make changes to the code? I have Tampermonkey, and when I click "Update to Version 1.3.5" I see that there's a "source code" tab I can click in which I can see everything, but I cannot make any changes to it before clicking "Update". How do I do this?
bhackelAutore
§
Pubblicato:
So once you have updated the script, click on the Tampermonkey browser extension icon, then click Dashboard, click on the script, then you can change the code (and remember to Ctrl+S to save). I didn't know tampermonkey had an autoupdate feature, but I usually update through greasyfork.
§
Pubblicato:
Modificato:
Sorry - I clicked "Update to Version 1.3.4" on the greasyfork website, and then it pulls up tampermonkey in a separate tab where I can view changes and the source code, and then have to click "Install". I was trying to make changes on this page and it wasn't letting me, but I found the extension icon and the dashboard thanks to your help.

I edited that line that was commented out and it seems that now only a single track plays and nothing else plays after it's finished, so that's great. However, when I navigate to soundcloud for the first time (or my profile page for example), for some reason a track starts automatically playing. It seems to be the most recent track that I uploaded. If I pause the track and refresh, it starts automatically playing again.
§
Pubblicato:
Modificato:
Also, somewhat interestingly, I noticed that when I turn your script off, autoplay seems to autoplay the tracks that I've listed as "favorites" (clicked the heart icon). However when I turn your script on (before you made the most recent change to it), autoplay would apparently be turned off but it would still autoplay tracks that I've uploaded and keep re-populating the queue (which is the second thing I complained about which you subsequently fixed, though I wondered why it would still be autoplaying regardless since autoplay was disabled). Now it seems nothing automatically plays after a track has finished (which is great), however, for some reason my most recently uploaded track starts playing when I visit soundcloud or refresh the page, even if I had paused it previously.

"I'm having some trouble understanding what you are looking for with clearing the queue. Since the script runs continually every 2 seconds, clearing the queue would mean that only the currently playing song would play."

When you said this, I was a bit confused - isn't this what this script originally set out to accomplish, or did I misinterpret the intention of this script?

In any case it seems to be working great now, with the exception of my own tracks automatically beginning to play when I visit the site.
bhackelAutore
§
Pubblicato:
The script's purpose is to disable the Autoplay Station (as you have seen), which says "Hear related tracks based on what’s playing now." This is not autoplay, but instead the playing of tracks that SoundCloud thinks you want to hear (which includes your favorites) after the queue is empty.

I'll see if I can fix the automatic playing of tracks at the start, but I'm having trouble replicating it.
§
Pubblicato:
Modificato:
Oh I see; I understand the distinction now.

The automatic playing (when the website is loaded/refreshed) only occurs when I remove the comment on line 63; otherwise it does not happen.

Thank you for trying; it's much appreciated! Personally, these changes are a huge improvement to my enjoyment of the website; I've already shared your script on reddit for anyone else who might be similarly frustrated as I was with this.

If it would be of any assistance I can make a video showing it happening, or anything else you might need from my system to troubleshoot; just let me know if so.
bhackelAutore
§
Pubblicato:
Figured it out - clearing the queue starts playback of songs. The fix for this will be a little hacky, but I'll update it soon.
§
Pubblicato:
Awesome! Looking forward to it.
bhackelAutore
§
Pubblicato:
Looks like it's all good now, let me know if there are any issues (remove comments on lines 66 and 72)
§
Pubblicato:
Seems to be working great! I assumed that the comments were /* and */ (instead of having to comment out every line). Thanks so much!

Pubblica risposta

Accedi per pubblicare una risposta.