LMB Single image

About: Pixiv Arts Preview & Followed Atrists Coloring
6 Jun modifié dans Discussions de script Chrome

Since version 1.00 LMB click on single preview don't open original, only about:blank, clicking on image in manga preview is ok, full size as expected. Tried Chrome, Firefox, Violentmonkey, Tampermonkey, with and without other extensions and scripts. Is it only my problem?

Thanks for this script, the best for pixiv.

Réponses

  • @milarin thanks for the feedback! Usually I try to test new new versions of script in main browsers(Firefox, Chrome, Opera) before uploading it. Right now, I've copied only both scripts in Tampermonkey/Chome, and it works fine...
    Can you do some of this:
    -open pixiv page where my script works, open developer console (press F12, "console" tab), make single LMB-click, wait for sec and make a screenshot of console, upload it on some free image-hosting and give me a link(I'm using -->Lightshot<--, PrtScr -> Select screen area -> Ctrl+D to upload it to internet - copy received link and paste here; or Ctrl+S after selecting area and then manually upload it somewhere). If nothing of this can be done, copy console content and attach it with .txt file or simply paste it here as is.
    -Can you fully uninstall both scripts, reload browser and then reinstall it and try again?(maybe you've already done this too)

    Note, that I'm testing scripts in Tampermonkey in all my browsers, so I don't sure script works fine with Violentmonkey, and I know for sure that in new Firefox it doesn't work with new Greacemonkey(but works with Tampermonkey).

    If someone else will submit same error - then we can sure it is not an accident and maybe get more information about under what circumstances this bug is happening.

  • 6 Jun modifié Chrome

    @NightLancerX Thank you for your reply.

    I have used Tampermonkey with reinstalled script.

  • @milarin Request had finished successfully, no errors reported, opening original should works... Sorry, I don't know for sure what might be the problem, since manga originals opens fine, and there is no code mistakes... It it was not - I'd suggest, that new tabs opening is not allowed for pixiv.net, or XHR fails(which is not, as can be saw from screenshot). You may try to make same screenshot on the "empty" new tab, if there is some error appearing it may be there.
    Ctrl+click, MMB-click, Alt+click - works fine? If so, I can hardly tell what's the problem now. You may still use 0.38 script version(disabling script autoupdates) with NewTabImageOpen (I've already deleted it from greasyfork, since it was no more need in it with 1.0 script version, but it has been left on github), maybe some time later it will work...

  • Ctrl+LMB don't work only with single images too, 404 error, MMB and Alt+LMB works. All works fine in manga mode, so it is a mystery. Empty tab don't contain anything, nothing in console log. I will try something here and on another PC. :)

  • Can confirm the same results as @milarin , exact same behavior. If I restart Chrome, it starts working again, but will stop working and result in about:blank seemingly random.

  • 8 Jun modifié Firefox

    @jlboi69 @milarin okay, now i see that it is not coincidence. But definitely strange behavior. Since I'm mainly use Firefox for web surfing, I only opened Chrome(and Opera) just to see that all actions works there. Now I see an additional Chrome testing is required to find out when exactly that bug appears.

    Thanks for the provided information, I will switch to Chrome for this weekend's and try to catch this bug.

  • @jlboi69 @milarin I've tried with and without second script, "referer control", but single click worked always in my case. Saving image with ctrl+click, obviously, have failed when I disabled second script.

    Did you using VPN on your PC while accessing pixiv? Or maybe some software protection product, like antivirus with web-screen, or Adguard? Because I've shared this script to my mate and it have worked fine.

    I've tried some other settings in Referer Control, you can it:

  • 9 Jun modifié Chrome

    @NightLancerX I don't use VPN, just tried with proxy once. Antivirus.. I use Comodo Firewall and disabled it for tests, firewall and HIPS, adblock extension too.
    Today I tried script on another PC, Win7, Chrome/Firefox, Kaspersky AV. Then on virtual machine with Linux and Chromium/Firefox, then bare metal Linux and Chromium. Result is the same.
    I'm not good in programming, but looked in console again in Network/Response tab and it has strange answer. I will send it to you in PM, maybe it will clarify the situation.

  • @milarin answered in PM.
    @jlboi69 added you too to the conversation. If you see my message there, you can try that too.

  • Dropping by to confirm the issue
    LMB only brings up about:blank

    Windows10 Firefox Beta/Nightly
    Clean profile with only Tampermonkey and this script

  • @gugugago i see, pixiv seems already released new artwork page layout on public(at least now I have it and I can make fix for it).
    Thanks for the information, I'll try to patch the script in the near future.

  • @milarin @jlboi69 @gugugago fixed, update the script.

  • @NightLancerX now all works great, thank you.

Connectez-vous ou Inscrivez-vous pour répondre.