Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

How to exculde "about:addons" for a script?

edited August 2014 in Development
I use a script which work for flickr, but it interfere with the about:addons page.

How can i exclude this page ?

Comments

  • Ctrl+Shift+A to addons page, go to "User Scripts", click "Options" next to the script you want to change its exclude urls.

    Then, add about:addons to exclude urls.

    My Firefox is in Chinese, but it should be similar.
    image
  • Thanks:
    But i try that, but it seems don't a working solution...
    with;
    // @exclude about:addons
    It work always on addons-page.
  • Thanks:
    But i try that, but it seems don't a working solution...
    with;
    // @exclude about:addons
    It work always on addons-page.
    Em... I don't know it then :< Sorry..
  • GreaseMonkey does not run userscripts on about: pages (except about:blank) since the fix in https://github.com/greasemonkey/greasemonkey/issues/1375

    Are you running Scriptish? It has a checkbox for running scripts in about: pages (according to a screen shot I saw somewhere).
  • edited August 2014
    i don't use scriptish.

    But i see many other userscripts witch run on addons-page when i click the monkey face...

    It seems a bug...
    Maybe the Australis?
  • edited August 2014
    I currently have GM 2.1 on Firefox 31.

    I created a script with

    //@include about:addons
    //@include *

    and it doesn't show on that page. Not sure why yours is so different.
  • that's strange....

    I have the same GM and Firefox version than you.

    I test on another profile and greasemonkey don't work on addons-page.

    What i need to do to find where is the problem?
    An other extension can interfere with greasemonkey?

    Ps: i join my extensions in use in this profile

  • edited August 2014
    Sorry, I did not test thoroughly enough.

    * If I open about:addons and the last category/list was anything except "Get Add-ons" then the monkey menu lists no scripts. If I switch to any category except "Get Add-ons" there still are no scripts enabled.

    * If I select "Get Add-ons" then the monkey menu will show scripts, and will continue to show scripts as I switch categories, until I close the page.

    "Get Add-ons" loads an iframe with a page from services.addons.mozilla.org and that is a permissible target for scripts. What is strange is that the monkey button continues to show scripts when you switch categories, but it could be that the iframe remains open in the page, just not displayed.

    If you are getting interference within the iframe then you know the domain to exclude. If you are getting interference outside the iframe, hmm, that's strange.
  • edited August 2014
    Thanks :
    that's good and i have same results than you.

    I add:
    // @exclude http*://services.addons.mozilla.org/*

    and the script don't work on the addons-page (it hanged a moment the page).

    But the persistence of the iframe is strange:
    maybe greasemonkey need an update.

    I add a copy of our discuss to :
    User scripts should not have chrome privilege in about: pages

    Ps :
    This problematic script is very "sensitive":
    If i make a change in it it stop working (like add an include)
    and reinstall it don't do the job .
    Delete / Copy just its problematic script folder is not enough too.

    I try many process, but the only working way is to copy the "gm_scripts" folder in a working profile folder to the not working Profile folder.


    That's a little bit weird !

    1 - Where are stored the infos about an particular installed GM to reset and reinstall it without problem?

    2 - It's a sqilte problem ?

    Before when we deleted a script , we see an option "delete all its preferences"

Sign In or Register to comment.