The block button cannot be clicked

About: Google Hit Hider by Domain (Search Filter / Block Sites)
The button shows when I hover on the link, but it's unclickable.

Comentarios

  • Hi Ooker, let's see if we can figure this out.

    I'm going to assume you're using Google. If you are not using Google, could you give the address of the results page where the buttons can't be clicked?

    It sounds as though you changed "Display block buttons" from "Always" to "On Mouseover" on the "Options" tab of the Manage Hiding dialog. With that setting: the button should appear if you hover anywhere over the result, it should turn yellow when you hover the button itself, and if you wait, a tooltip should appear explaining the result of clicking the button. That works for me on Google results this morning -- I can click the button -- but there are many others settings which could be coming into play.

    If your block button turns yellow when you hover it but clicking has no result, it's possible that the block dialog is not appearing. What happens if you turn on 1-click blocking? That's on the "Home" tab of the Manage Hiding dialog.

    Could you describe any other non-default settings you have for the script?

    In case you have a previously unknown Google results layout, could you test in a private window (a private window will not re-use cached pages from regular windows or previously set cookies) to see whether that makes any difference?

    Thanks.
  • Hi, I find out that the script is in conflict with the Google search tweaks script. For any link that has shortcut, the block button cannot be click. If I disable it, it works again. Thanks for your helping :)

    For more information, yes the button does turn yellow and show tooltip when I hover it. Changing the setting won't fix the problem.

  • You might try moving the block button to the cite line to see whether that helps. Also under Options, "Block button position (reloads):". I haven't tested with that other script.
  • Cite line displaying does not help either. By the way, what does it do when I ALT+click? I can't see any difference
  • Okay, I see the problem. Line 39 of the other script does a complete rewrite of the result using innerHTML. A known effect of that is to strip the click handler from my button. To fix this, you need to edit the other script:

    OLD LINE 39:

    gs[i].innerHTML = `<span style="position: absolute; left: -20px; top: 4px;">${i+1}</span>${gs[i].innerHTML}`;

    REPLACEMENT LINE 39:

    gs[i].insertAdjacentHTML('afterbegin', `<span style="position: absolute; left: -20px; top: 4px;">${i+1}</span>`);

    Let me know if that works for you.
  • It works, thanks. You are so helpful :smiley:
Accede o Regístrate para comentar.