Request

About: Google Hit Hider by Domain (Search Filter / Block Sites)
Could you please consider doing the fix needed for this script to work properly with the search preview firefox add-on?

https://greasyfork.org/es/forum/discussion/6490/x

Thank you.

Comentarios

  • As far as I can tell, GHHbD works with the SearchPreview extension without other modifications, at least on Google and DuckDuckGo.

    What's the complete combination of add-ons you need to work together? The old userstyle ( https://userstyles.org/styles/111772/duckduckgo-2-columns-and-numbered-results ) doesn't seem to work any more for me.

    (Also, why does the SearchPreview icon show the linked site's home page instead of the actual page linked in the result? This doesn't seem very useful to me.)
  • editado June 2016 Firefox
    Like you said on the previous talk we had last year your scrip when it adds the buttons to hide the results it breaks the result box and the results get all messed up

    I use this userstyle that I posted that was based on an other one that you helped me modify https://userstyles.org/styles/119609/ddg-simple-3-columns

    Here is how it looks with your script + search preview + DDG 3 columns

    http://www.imagebam.com/image/8e7211490029908

    Even if I disable DDG 3 columns the pic appears over the result instead of to the left

    Also even on google with search preview on even if it doesn't break the box for the results the button to block that result appears over the it blocking part of the text

    http://www.imagebam.com/image/bda02a490031663

    (IDK where the add-on gets the pics from but sometimes they are accurate sometimes they are not I think that it might get it from something like waybackmachine and if that subdomain didn't exist before it shows the homepage)
  • I will look at this in more detail.

    By the way, the Imagebam site launched a background window to a malware distribution site. Not sure if they are infected or it was an ad.
  • You could try this to shorten the heading link to make room for the button on DuckDuckGo:

    .result__a {width: calc(100% - 75px - 115px) !important;} /* room for button and thumbnail */

    The 75px is for the block button. The button isn't that wide, but gets partially blocked by the little history indicator. If you shorten the caption (for example, change block to X), you can reduce this number and show more of the title. The 115px is for the thumbnail.

    I can't reproduce the problem you have on Google. If you use an old custom style rule for a previous version of GHHbD, please test without it.
  • Actually, I like this better -- the button comes into view when you hover but otherwise the title can use the full space available:

    .result__title {overflow:hidden !important;} .result__title:hover .result__a {width: calc(100% - 80px) !important;}
  • That fixes it. Thanks a lot.

    Seems that I have an old version of your script. have you set your script to auto-update cause I remember the script not updating before as well?
  • Lemme test the second one you pasted.
  • editado June 2016 Firefox
    It's nice too but It works best if you set the option to only show the button on hover and instead of .result__title:hover you use .result__body:hover cause else it will only shorten while exactly over the title not over the box.

    I think I'll use and post the first one with -50px cause the button is ~45px long.

    have you set your script to auto-update cause I remember the script not updating before as well?

    Thank you again.
  • All userscripts should auto-update. However, if you edit a script in the Greasemonkey editor, that might block updating. (In the old days, you could unexpectedly lose your changes.)
  • I have it to edit on Notepad++ but I don't remember editing your script.

    Also other scripts like Handy Image did not get updated but anti-adblock killer and mouseover popup image did

    I haven't edited any of those either

    How does firefox or greasemonkey find the url to update them if they don't have the // @updateURL ?
  • Sorry to bother you again but I noticed that with the userstyle when you hide the result with your script the box for it still appears with the preview but without the title and the description.

    I noticed also that when using the userstyle duckduckgo multicol it works properly https://userstyles.org/styles/91647/duckduckgo-multicol

    would you mind helping me out figure how to solve this issue? Thank you.
  • editado June 2016 Firefox
    You can hide the preview image for results on the regular block list with this rule:

    #links .result[blocknotice]>img {display:none !important;}

    Removing permaban boxes is trickier because there are very specific display rules, but this should hide them:

    #links .result.ghhdnone{width:0!important;visibility:hidden!important;margin-left:-1000px!important}

    Does that work for you?
  • Thanks for your reply. The image gets hidden but at the end of the page the boxes for the hidden results show.

    http://www.imagebam.com/image/a4d82d490564506
  • I don't get the missing boxes back. To test:

    (1) I set the block buttons back to Always (instead of On Mouseover) and (2) I added the two custom style rules from my previous post.

    In case your screen is much higher resolution than mine, you could modify the negative margin, but it shouldn't be necessary:

    #links .result[blocknotice]>img{display:none !important;} #links .result.ghhdnone{width:0!important;visibility:hidden!important;margin-left: -3000px!important}
  • The same happens but is it fixable? cause the results load when you reach the bottom of the page and before that happens the page is full - x ammount of results blocked so there will be blank space there and when you reach the bottom of the page can the userstyle make it load on those blank spaces from the previous page?
  • Oh, maybe because you have DDG set not to show page breaks between results, there is a hidden page break. You can style that out by adding third rule:

    #links .result[blocknotice]>img{display:none !important;} #links .result.ghhdnone{width:0!important;visibility:hidden!important;margin-left: -3000px!important} #links>div[id^="rrd-"]{display:none!important;}
  • That fixed it. Thanks a lot. You are great.
Accede o Regístrate para comentar.