ChatGPT Auto-Continue ⏩

⚡ Automatically continue generating multiple ChatGPT responses

< Feedback on ChatGPT Auto-Continue ⏩


Posted: 2024-06-09

Hi! I have to start off by thanking you for this script! I've tested your script with both Firefox (126.0.1 (64-bit)) and Chrome (125.0.6422.142 (Official Build) (64-bit) (cohort: Stable)) on Windows 10, only Tampermonkey (5.1.1) and this script were enabled for both browsers, and I noticed that for Chrome the script is not executing while the window is in the background having ChatGPT as its only tab, in comparison to Firefox.

I also noticed the script doesn't execute for Firefox and Chrome when the ChatGPT tab is not visible (a different tab of the same window being visible instead of the ChatGPT tab), although I found this solution for Firefox, for this case:

    function clickButton() {
        const button = document.querySelector('\\:border');
        if (button) {

    setInterval(clickButton, 1000);

Is there any chance you could add these functionalities, if possible?

Posted: 2024-06-09

Hey @NWP thanks for using! I just tested, the script works for me in both FF and Chrome (the versions you specified) when they are background windows. But I am using Tampermonkey 5.2.0, can you update @ and confirm if issue still persists?

Re: when tab not visible, this is default Chrome behavior for any inactive tab process, but you can actually disable this sleeping by going to chrome://discards, look for the ChatGPT tab, and in that row click the "Toggle" in the "Auto Discardable" column to change the check mark to an "X" so it doesn't sleep:

In Firefox, with Tampermonkey 5.2.0 it still auto-continued for me when background tab, can you try it out?

Posted: 2024-06-10
Edited: 2024-06-10

With your latest version (2024.6.9) it now works for Firefox for both cases, with Tampermonkey 5.1.1, as 5.2.0 was not yet released to Firefox.

As for Chrome, with your 2024.6.9 version, none of the two methods worked, regardless of whether I was using Tampermonkey 5.2.0 or Tampermonkey Beta 5.2.6198. Before testing, this time, I opened cmd and navigated to the directory where chrome.exe resided, whose path was found in Executable Path in chrome://version. For me it was C:\Program Files\Google\Chrome\Application\125.0.6422.142\, so I had to use this command:

cd "C:\Program Files\Google\Chrome\Application\125.0.6422.142\"

Then I ran:

chrome.exe --user-data-dir="C:\Temp\ChromeProfile"

to create a new Chrome profile to make sure no internal flags were used (so no chrome://flags), or any other settings, basically acting like a clean Chrome install.

I then enabled Developer mode as it is now required for Tampermonkey to work. Also, I hit the Toggle button to make the X show up for the respective tab, and I repeated the test with ChatGPT 5 times for each of the two cases, totaling 10 tests.

The test consisted of printing the same block of code, consisting of about 400 lines of code, which would require your script to hit the Continue generating 2 times, but that never happened to Chrome for both cases, not even the first click was performed.

When you performed the test, were you using certain settings/flags for Chrome or certain settings for Tampermonkey? You mentioned the window being in the background, did you mean it being maximized in the background, as that's how I've done it for both Chrome and Firefox?

Posted: 2024-06-11

I made a mistake, this should be the command instead for navigating to the chrome.exe directory:

cd "C:\Program Files\Google\Chrome\Application\"

Posted: 2024-06-11
Edited: 2024-06-11

It seems disabling the Calculate window occlusion on Windows flag, from chrome://flags, allows for Auto Continue to work only when the Chrome window is in the background but its Chrome Chat GPT tab is active. It worked for 4/5 times for the same test. Having the X showing up for the Chat GPT tab, from chrome://discards, didn't make any difference.


I've read something about using a web worker, maybe that will fix the other issue.

Thanks for fixing it for Firefox!

Post reply

Sign in to post a reply.