gm4-polyfill-mach6-legacy

This utility is designed to ease authoring user scripts compatible with both Greasemonkey 4 and other/older user script engines.

This script should not be not be installed directly. It is a library for other scripts to include with the meta directive // @require https://greasyfork.org/scripts/373124-gm4-polyfill-mach6-legacy/code/gm4-polyfill-mach6-legacy.js?version=839554

Author
mach6
Ratings
0 0 0
Version
1.3
Created
2018-10-11
Updated
2020-08-20
License
GPL
Applies to
All sites

Provide backward support for legacy API. Slightly modified from the original one

this version doesn't need support of arrow function/let/Pbject.entries

https://greasemonkey.github.io/gm4-polyfill/gm4-polyfill.js

https://greasyfork.org/en/scripts/372965-gm4-polyfill-mach6

The git repo is at https://github.com/machsix/Super-preloader/blob/master/polyfill/gm4-polyfill-mach6-legacy.js