Local YouTube Downloader

Download YouTube videos without external service.

< Feedback on Local YouTube Downloader

Question/comment

§
Posted:
Edited:
I can't seem to see any download buttons. All I see is the "show/hide" links button, which opening just shows me a small drop down with the words "Stream Video ID: Adaptive" and a link underneath all of that to an online video and audio merger.
I am using Tampermonkey on Google Chrome. I tried disabling every other extension, and this is the only script Tampermonkey is running, so that can't be it. I checked several other videos so I know its not just the one video that's causing issues.
maple3142Author
§
Posted:

I don't know. It works for me and I can't fix issues that I don't have. You could try login/logout your google account.

§
Posted:
Edited:
same thing here. kinda bad

chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?name=Local%2520YouTube%2520Downloader.user.js&id=59991e84-2fbd-4bcf-ba75-1c6d85fb40e6:11990 YTDL: load TypeError: Cannot read property 'js' of undefined
at load (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?name=Local%2520YouTube%2520Downloader.user.js&id=59991e84-2fbd-4bcf-ba75-1c6d85fb40e6:12581)
at Window.eval (chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?name=Local%2520YouTube%2520Downloader.user.js&id=59991e84-2fbd-4bcf-ba75-1c6d85fb40e6:12639)
at :3:100
at E.z. (eval at exec_fn (watch:1), :43:442)
eval @ chrome-extension://dhdgffkkebhmkfjojejmpbldmpobfkfo/userscript.html?name=Local%2520YouTube%2520Downloader.user.js&id=59991e84-2fbd-4bcf-ba75-1c6d85fb40e6:11990
maple3142Author
§
Posted:

It works for me:

§
Posted:
Edited:
well that's crazy but for now it dosent work for others
this is what bugs according to the console
§
Posted:
Try Violentmonkey. Had same issue on Firefox with Greasemonkey.
maple3142Author
§
Posted:

Greasemonkey is not compatible with other userscript manager. This script doesn't support it at all.

§
Posted:
Stopped working here. I am attaching the relevant part of the console.
maple3142Author
§
Posted:

I CAN'T fix problems that I don't have, so this can't be fixed until I encounter it.

§
Posted:
bad dev, we literally giving the full error log and "nah i dont have i cant fix" you know other devs face issues they dont have too and still attemp fixing.
Will leave a downvote for now
maple3142Author
§
Posted:

Becuase that error log isn't enough. What I need is a enviroment where error happens, but I don't have.

§
Posted:
Now it works.
It seems that youtube is making some test changes in random pages (maybe on selected datacenters) and the script that depends on it do not work. I had some similar issues with my (commercial) project.
§
Posted:
Nope, doesn't work. While I agree that it looks like YT makes and/or made changes and sometimes (on some videos) it worked yesterday but today it didn't work on a single video. I tried Tampermonkey and Violentmonkey, just to make sure. I even downloaded a fresh copy of Firefox portable with just Tampermonkey and this Scrip installed.

@ Maple
Can we help somehow? I mean I could provide you with a pre-configured copy of Firefox 82.0 portable if you want.
§
Posted:
Same issue happened to me today..
maple3142Author
§
Posted:

New version is just published, maybe it will fix the problem

§
Posted:
Edited:
10/27 Just tested. Unfortunately the problem still exists. :/
10/28 Today all videos I tested work again. Thanks.

Post reply

Sign in to post a reply.