Image Max URL

Finds larger or original versions of images and videos for 8000+ websites, including a powerful media popup and download feature

< Feedback on Image Max URL

Question/comment

§
Posted: 2021-04-23
Good day!
I cannot open the video in a window on Reddit.com
On YouTube, it works.
This used to work on Reddit.com but now it doesn't.
What can I do to make this work on Reddit.com?
qsniygAuthor
§
Posted: 2021-04-23

Strangely enough, someone else reported this too a few days ago.

Could you do the following?

  • Open the browser console (F12)
  • Reload the page
  • Open the popup (so that it fails to load)

Check if there are any errors printed. In the other person's case, the error was something like:

{
    "finalUrl": "https://www.reddit.com/api/info.json?id=...",
    "responseHeaders": "...",
    "readyState": 4,
    "status": 403,
    "statusText": "",
    "response": "Blocked",
    "responseText": "Blocked",
    "lengthComputable": true,
    "loaded": 7,
    "total": 7
}

If that's the error you have, I'll have to find a different (and unfortunately less efficient) way to query posts.

If it's not the error you have, can you share what it is? (screenshot should be fine). If it contains anything personal, feel free to redact or send it to me privately (contact info is here: https://qsniyg.github.io/)

§
Posted: 2021-04-24
I do not understand..
1) I go to reddit.com
2) I press (F12) which tab? Elements, Console, Sources, Network, Perfomance, Memory or Application?
3) Reload the page.
4) (Check if there are any errors printed.) Where to look?
qsniygAuthor
§
Posted: 2021-04-24
Sorry, F12 -> Console tab.

There should be errors (in red) printed on the console tab once you open the popup.
§
Posted: 2021-04-24

Record a short video, please. Video about where to look (errors printed). Where to look???

{
    "finalUrl": "https://www.reddit.com/api/info.json?id=...",
    "responseHeaders": "...",
    "readyState": 4,
    "status": 403,
    "statusText": "",
    "response": "Blocked",
    "responseText": "Blocked",
    "lengthComputable": true,
    "loaded": 7,
    "total": 7
}
§
Posted: 2021-04-24
i don't know
§
Posted: 2021-04-24
Edited: 2021-04-24
When I click on the video to receive (popup) errors appear in the console. (Page not found)
qsniygAuthor
§
Posted: 2021-04-24
Ah, it's a different error! Can you share a link to where it fails (and where on the page you opened the popup)? Are you using the new or the old reddit? It's likely a video
§
Posted: 2021-04-24
I use it on reddit.com homepage
reddit.com has a new design included.
I hover over any video on the reddit.com homepage and nothing appears.
Исходный текст
Any video on reddit.com won't open in a new window.
This only works with photos on reddit.com
It used to work with video now it doesn't work.
qsniygAuthor
§
Posted: 2021-05-03

Sorry for the late reply, I can replicate it now! Should be fixed with: https://github.com/qsniyg/maxurl/commit/c2289de82062eb2f8ad1e131ac36d32db0b978e1

§
Posted: 2021-05-04

I cannot find it in the code. My code is different

How do you correctly apply the new changes? I am looking for a copy of the code and replace it with a new one. (with hands)

Example: I cannot find it in my code

if (host_domain_nosub === "flickr.com") {
§
Posted: 2021-05-04
I installed this version but the video on reddit.com still cannot be opened in the window.
You have to try it yourself, it doesn't really work.
Example this video: https://www.reddit.com/r/nextfuckinglevel/comments/n4rb4e/nightboarding_20_feat_6_huskies
Try opening it in a window.

P.S. I have Windows 10 pro and google chrome last version, and Image Max URL 0.19.0
§
Posted: 2021-05-06
I will wait for the solution to the problem.
It was very easy to use!
I would like you to fix this.
When you have the opportunity :)
qsniygAuthor
§
Posted: 2021-06-20
Edited: 2021-06-20
Sorry for getting back so late, I wasn't able to reproduce the problem at all.

Turns out that the issue was due to the user agent string, Reddit blocks requests by some of them, primarily latest chrome under windows, which matches your setup.

These two commits should fix it: https://github.com/qsniyg/maxurl/commit/6a1cba9af89c0a7d60b429cbca60be3a5dc7d063 and https://github.com/qsniyg/maxurl/commit/00d2189984d025778072b87b619ca2e76e7260cf , see if they work for you :)

As I mentioned earlier, you can use https://github.com/qsniyg/maxurl/blob/master/userscript.user.js?raw=true to test.

Post reply

Sign in to post a reply.