Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Once again the script is broken

About: GoogleMonkeyR
Getting blank screens where the results should be, and the "number of pages" clocks up automatically once every second. Please fix.
«1

Comments

  • edited July 2015 Firefox
    Hello, I made a change to the script that solved the problem for me. Tested on Firefox 39.

    Click my link below to install automatically:
    https://greasyfork.org/scripts/11136-googlemonkeyr/code/GoogleMonkeyR.user.js

    Or if you want to do it manually, find this line:
    var list = document.getElementsByXPath("//div[@id='ires']//li[contains(@class,'g')] | //div[@id='ires']//li/div[@class='g']");
    and replace it with this line:
    var list = document.getElementsByXPath("//div[@id='ires']//li[contains(@class,'g')] | //div[@id='ires']//li/div[@class='g'] | //div[@id='ires']//div[@class='g']");
    Here's a preview image:
    image


    Edit: Oh, I also made an additional change from Boltex' last revision of this script (mentioned in the 1.7.2 changelog). The change makes it so the search results should scale according to window width. If you'd like to try it out, find this line:
    style += ("hr.rgsep { margin: 0 -15px 16px; } #extrares.med {padding: 0 !important} #cnt.singleton #center_col, #cnt.singleton #foot, .mw {width:1240px !important;} #rhs {left:auto !important; position:absolute}#botstuff .sp_cnt,#botstuff .ssp, #ires{display:none} .s{max-width:98%!important;} .vshid{display:inline} .ab_dropdown ul{list-style:none} #GTR *{white-space:none!important} #GTR{border-spacing:5px} #rcnt .col:nth-of-type(3){width:100%!important} #rcnt .col:nth-of-type(4){float: none; right: 0px; top: -140px; width:100% !important}");
    and replace with:
    style += ("#cnt.singleton #center_col, #cnt.singleton #foot, .mw {width:auto !important; max-width:100% !important;} #rhs {left:auto !important; position:absolute}#botstuff .sp_cnt,#botstuff .ssp, #ires{display:none} .s{max-width:98%!important;} .vshid{display:inline} .ab_dropdown ul{list-style:none} #GTR *{white-space:normal!important} #GTR{border-spacing:5px} #rcnt .col:nth-of-type(3){width:100%!important} #rcnt .col:nth-of-type(4){float: none; right: 0px; top: -140px; width:100% !important}");
    This change is already included in my download above.
  • @Kilvoctu: Please fix "auto load more results" too
  • Tu Tran -> Thank you for update :)
    but i miss autoload :(
  • edited July 2015 Chrome
    I don't personally use the auto load feature, but if I have time I'll look into it and see if I can figure anything out.
    Probably we need someone with more expertise, since I am an amateur; in the meantime turn off auto load in the preferences.
  • Thanks a lot kilvoctu.
  • edited July 2015 Firefox
    @kamikize @SGOrava

    Please try this fix for autoload. It works on my set up so hopefully it works for you.

    Download new version here:
    https://greasyfork.org/scripts/11136-googlemonkeyr/code/GoogleMonkeyR.user.js

    Or change manually this line:
    var list = document.getElementsByXPath(".//div[@id='ires']/ol/div[starts-with(@class,'srg')]/li", nextResult);
    to this line:
    var list = document.getElementsByXPath(".//div[@id='ires']/ol/div[starts-with(@class,'srg')]/li | //div[@id='ires']//div[@class='g'] | //div[@id='ires']//li[contains(@class,'g')]", nextResult);
  • Little thing, but would it be easy to fix the image results so they line up horizontally, like they do without GoogleMonkeyR? In particular, there is now a "Images for ..." that seems to appear as the first result on the second page.
  • I'm not a javascript developer, so honestly none of this is easy for me, lol.

    I guess what's happening is the script is treating the "Images for [x]" as a separate search result, as opposed to enclosing the pictures within it. Hopefully someone who knows some syntax and stuff can chime in and assist, since I assume in this community there are a lot of people who actually know what they're doing.

    For me, as long as everything more or less works, it's fine. :)
  • @Kilvoctu : Thanks, it works !
  • It does work the same as the link on top a little autoload, when scrolling really down, so 3 lines are refreshed. Recognize the white blank space on the bottom?

    https://i.imgur.com/mCSmpXs.png

    Thanks for your efforts! Looking forward you solve this!
  • It seems that you can only autoload some unspecified number of pages before it stops working. I tried just now with a query for "googlemonkeyr": the first time I got 23 pages, the next was 18 pages, then a third time for 28 pages. I was able to get further if I scrolled more slowly.

    I was prompted with a captcha after each time, so I assume after loading too many pages too quickly that Google requires a bot check on the user, and the script isn't able to deal with that. For all I know, I could be totally wrong, too.
    Again, we'd probably need a more experienced user to assist.
  • edited August 2015 Firefox
    @Kilvoctu, add a new exclude line after all the //include lines (and post a new version please) :
    // @exclude *&tbm=nws*
    // @exclude *&tbm=vid*
    After I added that line google stopped showing me all the captcha pages .
    It has another advantage. The scripts will stop loading in "videos" "news" etc... and no more missing thumbs of videos/news items when autoloading to the next pages.
  • edited August 2015 Firefox
    OK I have a correction. My suggestion (to add @exclude *tbm=nws* and also @exclude *tbm=vid* ) does stop the capcha pages when scrolling "videos" and "news" of version v.1.7.3.1 but Kilvoctu you are correct, I've followed your steps and on third time ( on the first 2 times I got 28 pages) I also got a captcha page.
  • Can someone upload this script as soon he thinks it's fixed! unf totally not the coder guy :( highly appreciated!! H
  • edited August 2015 Firefox
    @hannesgrebin, You can install Kilvoctu last version v.1.7.3.1
    https://greasyfork.org/scripts/11136-googlemonkeyr/code/GoogleMonkeyR.user.js

    and then :
    Open about:addons (Firefox addons-manager)
    > Userscripts > GoogleMonkeyR > Options > User Settings > Excluded Pages > Add
    // @exclude *&tbm=nws*
    // @exclude *&tbm=vid*

    There's a good chance that Kilvoctu will take my advice to exclude *&tbm=* "inside" the code itself so people would not need to add it manually.
  • Thanks :)
    Autoload work perfectly for me :)
  • Good work :
    Thanks to him !
  • edited July 2015 Firefox
    @LL25255252 I did put that exclude line in and tried it out, but it doesn't do anything beneficial for me. The number of autoload pages is still limited and I still get hit by a captcha, as you noted. Edit: and yes, this is on "Web" tab. It does not work ok for me.

    Naturally, what this line does is completely disable the script for any Google search tab that isn't "Web", so Videos/News/Books/etc won't have GoogleMonkeyR functional. The user would need a different script/plugin to do columns and autoload and such for those tabs. It's more of a personal choice than something I believe should be imposed on anyone who downloads the script.

    As for why some thumbnails won't load on page 2 and up for autoload, it might be a similar incident to everything thus far regarding the script not looking for certain web element to display.
  • edited July 2015 Firefox
    @Kilvoctu, except the special case you described on July-24, "WEB" now works OK (and without captchas) .

    But I think we must for now (until someone comes with a fix) disable Videos/News/etc.
    Because If I try for example "videos" l get problems after 2-5 seconds of scrolling.
    I tried it for a couple of times. On some of the tries it got into a loop. Suddenly the page number started to go up in a loop. I stopped it on page 42 (as I can remember) by closing the tab. And of course I was "punished" with a captcha afterwards .

    When I search for something I (and I think most of the other users) mostly use "WEB" so It's better for now not to have GMR on "videos/news" than to risk a crash/loop and to be punished by a captcha.
  • BTW - I recommend to everyone to add a "youtube" hyperlink next to to the "videos" by installing wOxxOm's script.
    https://greasyfork.org/en/scripts/7784-google-youtube-search-link
    I personally prefer most of the times to get "youtube" search results page than google's "videos" results page.
  • edited July 2015 Firefox
    @Kilvoctu Your file is also not working. Search results disappeared.

    The setting button on the top-right when I'm searching (but there is no "googlemonkeyr" button in the main page of www.google.com) is OK, but I can‘t modify the options. look the picture

    BTW, The version number shows 1.0??? Werid
  • @Potato Try deleting your script and re-download. There's no reason why the script should say v1.0.0 in the settings menu.
    Open up the script file and make sure it's the correct one.
  • edited July 2015 Chrome
    Thanks a lot @Kilvoctu, for putting this out and @LL25255252 for mentioning! favourite script for me!!! -
    just an idea to enhance this script: Is there a way to catch and show the time stamp of all websites in each label or is this site dependent? only to get an overview for which results are relevant and up to date? Thanks!

    H
  • edited July 2015 Firefox
    @Kilvoctu Yes, I did deleted the old file and download the link you give. No use. It's the same.

    The under of js also shows me a blank of search results but auto-page seems to be working. The author had deleted the file from his page. It should be the reason
    https://github.com/TimidScript/UserScripts/blob/master/scripts/Schmoogle.user.js
  • @Kilvoctu, can you please tell me if your experience with "videos"/"news"/etc is the same as mine (as described on my july-26 post) ?
    For me these "videos"/"news"/etc are totaly uncomaptible with the last script version.
  • kamikize said:

    @Kilvoctu: Please fix "auto load more results" too

    find
    var list = document.getElementsByXPath(".//div[@id='ires']/ol/div[starts-with(@class,'srg')]/li", nextResult);
    and replace it with the following line:
    var list = document.getElementsByXPath(".//div[@id='ires']/ol/div[starts-with(@class,'srg')]/div[@class='g']", nextResult);
    "auto load more results" fixed.
  • @LL25255252 Didn't notice anything out of the ordinary. Each search tab works as fine as the others with the script I uploaded.
    Potato said:

    The author had deleted the file from his page. It should be the reason
    https://github.com/TimidScript/UserScripts/blob/master/scripts/Schmoogle.user.js

    I don't know anything about Schmoogle. Contact the author of that one. He seems to be busy, though.
    https://greasyfork.org/en/forum/discussion/5199/ts-schmoogle-and-googlemonkeyr-seems-broken-by-a-google-change#latest
    Probably incompatibility.
  • edited July 2015 Firefox
    Potato said:

    @Kilvoctu Your file is also not working. Search results disappeared.

    The setting button on the top-right when I'm searching (but there is no "googlemonkeyr" button in the main page of www.google.com) is OK, but I can‘t modify the options. look the picture

    BTW, The version number shows 1.0??? Werid

    I have the same problem :
    Your fix work only on one of my profile i use for test.

    On the other, i have the same MonkeyR settings problem ( v1.0.0) which can't be close after i open it and not retain any preferences.

    And the search page not show any results:
    They seems loaded - i see the counter - but they are hidden (with firebug i can't find them).


    Why only one profile work with your fix, that's a mystery.

    I try
    - cleaning my profile folder (no twice monkeyR in them)
    - Delete and reinstall
    - copy the working code to an not working code
    etc..
    without any results..


  • @Kilvoctu - thank you! Your script 1.7.3.1 works for me. Outstanding work.
Sign In or Register to comment.