Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Stopped working

About: GitHub Dark Script
Seems to need an update. Stopped working used with Violentmonkey, I didn't try with other script loaders. CSS isn't replaced, keyboard shortcuts g+0 and g+- don't work.

Comments

  • Hi! I just tested this in ViolentMonkey for Chrome and everything is working as expected. Are you seeing this issue in a different browser? Do you see any errors in the console? Please try disabling all other userscripts and testing again.

  • Did you somehow disable your browsers CSP? Github updated their Content Security Policies and don't allow to load script-src any more:

    18:20:49.010 Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src"). Source: !function e(a){var b=document.querySelec.... :1

    Therefore jQuery can't load. Tested on 3 machines (3 locations), 2 browsers each.

  • It works fine on help.github.com and blog.github.com where no Content-Security-Policy header is being returned in the response but not on github.com.

  • The GitHub-Dark Script doesn't use jQuery. It is loading the style from GitHub, so there shouldn't be an issue with CSP. Have you tried using our usercss version? You'll need to install Stylus; it allows you to install a style and alter the custom settings.

  • My bad, I saw "query" and assumed it's jQuery.

    Don't know what it is, I don't recognise the source quoted in the error message. I kind of hoped you would. Unfortunately, when javascript injected into the root document ("self") fails to inject another resource error message always points to the first line of the HTML (hence ":1") instead of the line where the loading actually happens.

    Didn't try usercss version, I'm not interested in installing another plugin, sorry. Was just trying to help solve the issue of something being loaded in a subcall from outside of what's allowed in GitHub's script-src parameter of their CSP header and therefore getting blocked by the browser. I can always use another script if you're not interested in fixing this one, no biggy.

  • Sorry for not following up sooner. We are interested in getting our script to work, but if we can't fix a problem if we can't duplicate it or figure out the cause. Did you ever find out the cause of the issue you were seeing?

  • Work fine for me with Waterfox 56.2.1

  • Err... Sorry for lack of response. I never get notifications from greasyfork for some reason. AFAIR it turned out GitHub's policy is country dependent and they've updated the one for my region... or fixed my IP showing wrong region...? Something like that. I didn't understand but it's solved now. Marking as good.

Sign In or Register to comment.