Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

What version of firefox is requred?

About: JR Mturk Panda Crazy

Every time i go to the url https://worker.mturk.com/requesters/PandaCrazy/projects, i see "Sorry, we couldn’t find that page

Strange... the page you were looking for is not here. Let’s go home and try again." So something is happening that is not triggering Panda Crazy to load. I'm running firefox 57.0.4 on Linux Mint.

Comments

  • It should work with firefox newest version but you have to use tampermonkey. Greasemonkey was changed too much for it to work properly. I don't have Linux to test it in so I am not sure if it will work perfectly.
Sign In or Register to comment.