Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

No longer working in Chrome

About: Stig's Facebook Homefeed Cleanr
Hi, this script has worked well in the past but recently in Chrome on OS X w/ Tampermonkey it no longer blocks or highlights sponsored posts.

Also, I no longer see or know how to bring up the settings screen/popup. For a week or so it showed up every time I visited Facebook even though it said it should only pop up once, but now it stopped doing that and I don't know how to bring it up at all.

Comments

  • Thanks for feedback. I'll take a look at it after work.
  • edited December 7 Firefox
    I have reverted some code while investigating why my new code breaks in Chrome. Hopefully it will work again for you now - or as soon as the script has been updated in your browser.

    The info popup was only meant to be shown once. Does it still (again) popup every time you visit Facebook? Are you maybe surfing Facebook in Incognito mode or clearing cookies and local storage every time you close the browser (or leave Facebook)?

    You should always be able to bring up the Settings dialog via the dropdown-menu on Tampermonkey icon. Look for the menu-item "Homefeed Cleanr Settings". Check your settings, and if mode is correctly set to "Highlight posts" or "Hide posts" depending on your preference.
  • Hi again

    Now I believe I have fixed the error in my new code (Works for me with Chrome/Tampermonkey on Windows), and I have once again updated Facebook Homefeed Cleanr (version 2017.12.07.3).

    Let me know if it also works again for you, and also please give some details on your setup (do you use Incognito mode etc?) if you keep seeing the popup every time you visit FB.

    /Stig.
  • Thanks man! Everything's working again. I can access the settings dialog, I got the info popup just once, and it is blocking/highlighting sponsored posts.
Sign In or Register to comment.