Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

update needed

About: Harem Heroes++

the script need a update
he actually dont work on the last firefox version ( 57.0 )
work perfectly before the update of firefox

Sign In or Register to comment.