Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Script can't work in Firefox with tampermonkey

About: Evernote Web HTML editor
Hi, when I run the script in firefox with Greasemonkey or Tampermonkey, it's not working, could you make a support for firefox?

Comments

  • It's working fine on Firefox with Greasemonkey. The code is tested on both Firefox and Chrome each time it is released.

    Are you using Evernote or Yinxiang Biji?

  • I test it on Evernote and at last want to use it on Yinxiang Biji.

    In Chrome, the script works fine both on Evernote and Yinxiang Biji.

    Just for test, I download a portable Firefox from: https://portableapps.com/apps/internet/firefox_portable

    then run the script with Greasemonkey, and there is no response when click the button.

    Greasemonkey log

    with Tampermonkey, there is an error:

    Tampermonkey log

  • I have never tested Tampermonkey on Firefox. Can you please tell me what version of Firefox and Greasemonkey you are using?

    Thank you.

  • Test on windows7,

    Firefox 54.0 (64-bit), download from: https://portableapps.com/apps/internet/firefox_portable

    Greasemonkey: 3.11

    Tampermonkey: 4.3.5447

  • Whoops, apparently I was testing an unreleased version on Firefox. :innocent: Sorry about that. I have updated the code and taken into account the fact that Evernote serves different HTML codes to Firefox and Chrome (weird, but it's like that).

    Please try the new version 3.2.2.

  • It works now, many thanks for your help! :)

  • Great! :wink:

Sign In or Register to comment.