Greasy Fork is available in English.

UserscriptAPIWeb

https://gitee.com/liangjiancang/userscript/tree/master/lib/UserscriptAPI

Dieses Skript sollte nicht direkt installiert werden. Es handelt sich hier um eine Bibliothek für andere Skripte, welche über folgenden Befehl in den Metadaten eines Skriptes eingebunden wird // @require https://update.greasyfork.org/scripts/432003/1381253/UserscriptAPIWeb.js

Autor
Laster2800 Liang
Version
0.0.1.20240522153443
Erstellt am
06.09.2021
Letzte Aktualisierung
22.05.2024
Lizenz
n/a

UserscriptAPI

My API for userscripts.

需要引入模块方可工作,具体使用请参考源代码中的 JSDoc。点击查看 更新日志

所有模块均依赖于 UserscriptAPI,详细信息如下:

模块 依赖模块 Greasy Fork
base BuiltIn
dom 431998
logger BuiltIn
message dom 432000
wait 432002
web 432003

必须先引用 UserscriptAPI 再引入模块,如:

// @require     https://www.example.com/UserscriptAPI.js
// @require     https://www.example.com/UserscriptAPIDom.js
// @require     https://www.example.com/UserscriptAPIMessage.js
// @require     https://www.example.com/UserscriptAPIWait.js
// @require     https://www.example.com/UserscriptAPIWeb.js

补充说明

  • 脚本库基于 Microsoft Edge 浏览器和 Tampermonkey 脚本管理器开发,不支持 Greasemonkey。要求 Edge / Chrome / Chromium 内核版本不小于 93,Firefox 版本不小于 92。

Source: Gitee / GitHub - by Laster2800