Greasy Fork is available in English.

StarTube

Adds a bunch of customization options to V3

< Feedback on StarTube

Review: Good - script works

§
Posted: 20. 05. 2024
Edited: 20. 05. 2024

I’m glad you added the later video players since I was hoping you would do this for awhile (I wanted to ask if you would do the 2011-2012 Video player but tersiswilvin already made it as a usescript so idk) I did notice some bugs with the new players

1. The full screen button’s hovering animation is somewhat broken when in full screen mode (only happens on 2015-2016 player)
2. The volume slider sometimes doesn’t disappear all the way when you stop hovering over it (only seems to happen when in full screen mode)
3. Not a bug but the settings menu doesn’t have a unique design yet (which I hope you get around to doing)
4. The share button doesn’t have text when hovering over it (unless this is intentional?)
5. The “Click for Settings” pop up doesn’t have the settings cog next to the text

I also noticed that when trying to use the flat logo (2015-2017) on the 2019 Kevlar layout preset in favor of the ringo/invert logo it either doesn’t change the logo or it reverts the layout back to hitchhiker which I’m sure this happens with the other logos too. I was trying to go for the early Kevlar experiment look from 2016, is there a workaround for this? Or has compatibility not been implemented yet?

§
Posted: 20. 05. 2024

I also forgot to mention that the loading animation on the 2015-2016 player and 2016-2020 player hasn’t been changed to the default google loading animation

lightbeam24Author
§
Posted: 20. 05. 2024

Not a bug but the settings menu doesn’t have a unique design yet (which I hope you get around to doing)

I don't know if that's even possible. The menus are far too different and I don't know if making a custom menu is feasible in the case of the player.

The “Click for Settings” pop up doesn’t have the settings cog next to the text

I don't know what you're talking about.

I also noticed that when trying to use the flat logo (2015-2017) on the 2019 Kevlar layout preset in favor of the ringo/invert logo it either doesn’t change the logo or it reverts the layout back to hitchhiker which I’m sure this happens with the other logos too. I was trying to go for the early Kevlar experiment look from 2016, is there a workaround for this? Or has compatibility not been implemented yet?

The Polymer layout overpowers all other logo preferences, as it uses an SVG for its logo, rather than an image. Eventually an option for the old logo's SVG will be added, along with the general 2016 Polymer look.

I also forgot to mention that the loading animation on the 2015-2016 player and 2016-2020 player hasn’t been changed to the default google loading animation

This is not planned. I don't even know how to implement that animation. Besides, that animation wasn't added until very late 2017.

§
Posted: 20. 05. 2024

I’m talking about the settings gear icon that appears when you turn on captions and I’m quite suprised the loading animation was changed a bit later.

Post reply

Sign in to post a reply.