Greasy Fork is available in English.

Netflix - subtitle downloader

Allows you to download subtitles from Netflix

< Feedback on Netflix - subtitle downloader

مراجعة: Good - script works

Posted: 31-07-2020


I used Netflix Subtitle Downloader for about one month for downloading japanese subtitles from Japanese Netflix. All this time, the script worked perfectly. It is a really amazing solution, thank you for your great work!

However from yesterday downloading stopped to work. I mean the options “Download subs for this episode” and “Download subs from this ep till last available” appear on the screen, but nothing happens when I click them. (Editing of “languages to download” is available as usual.)

(Additional information: Simultaneously with the script, the Subadub extension also stopped working.)

I've tried a variety of methods to fix the problem, including completely uninstalling Chrome and reinstalling it and the script again, but nothing works. Precisely speaking, once the script recovered itself without any action on my part for about ten minutes, but then (after ten minutes) it stopped working again.

Please tell me what is the problem and how can it be solved?



Posted: 21-08-2020

Not sure what could be the issue. This script uses two tricks:

  • one is to enable all available subs - this doesn't work for all shows. Works fine for Stranger Things but doesn't for Lucifer,
  • another is to grab subs in text format - Japanese subs are loaded as images on Netflix but they use text format for iOS app if I recall correctly. Thanks to this my script can download subs.

Maybe the show you wanted doesn't have subs in text format? Or maybe it's something else. Try opening the console (F12, console tab) and see if there's any error after you click the download button. I just tested on Stranger Things and was able to download all subs without any problem.

Posted: 05-09-2020

Hello... I live in Greece , i download dubtitles from netflix using this script for a year but i have the same problem.. Its been some days that i see the download option but nothing happen when i click them.. I also tried unintalling and reintalling everything but still nothing happens.

Post reply

تسجيل الدخول إلى مرحلة ما بعد الرد.